Transparent caption container

New user - is it possible to make the ‘translucent’ caption box completely transparent but retaining White text, also edit the ‘Text’ of the caption to show in a specific font other than the programme default.


For a text caption, you have the choice of one single background color for the entire text block. This color is a RGBA quad (Red, Green, Blue, Alpha) where alpha is the % of opacity (or transparency) of the background color.

For the text itself, you can set the Font, Size, Style, and Color of every letter individually. To do this, select the text that you want to edit, then click the Color box to adjust the color.

Hint: the text will anti-alias towards the background color’s RGB values, even if the Alpha is zero (fully transparent). Usually, you’ll want to pick either Black, White, or neutral Grey for this to get the best look (it depends on the color of the text, and the color of the images that you are overlaying, as to what looks best). Feel free to experiment.

Also – iScreensaver 4 is smart about fonts: all text data is pre-rendered at build time into a graphics object. This means that, as an author, it doesn’t matter what fonts are on the end-users’ PCs.

New user: How do I turn the captions completely off. Can’t find the switch…

There are a few ways:

  1. On the Info window, Behavior tab, Overlays subsection: you can disable the Text or Image overlays completely.

  2. Select all items in the sequence, then simply type something in the overlay text field and then delete it. This will multi-edit all items at once, leaving the overlays enabled, but empty.

#1 is probably the better solution.

Thanks. I had tried #1 and it didn’t seem to work, but I tried it again, saved the Project, reloaded the Project, and it worked.

Well, I spoke too soon. The Captions disappeared from the Preview, but still show up on the Windows installed screensaver.

OK. #2 worked on the installed screensaver. I selected all 150 images, selected Captions, added a character, deleted the character, generated a Win build, and the Caption disappeared. Don’t know why the Captions Overlay switch doesn’t seem to work for me.

Thanks for your help!

It’s possible the captions overlay switch is broken, but we’ve never heard that before. – My guess as to the reason #1 didn’t work is that you didn’t actually install the new screensaver, but the old one was still running.

Windows is notorious for cacheing the old file, especially if you are copying files via a website. One trick to use in this case is to always change the filename for each build, e.g. “MyScreensaverInstaller001”, “MyScreensaverInstaller002” – that way you can be sure you are actually loading the version you think.

I’m almost embarrassed to ask this, but is there an overlay switch for the “Created with iScreenSaver” logo which flashes on every image? I suppose I could have missed a discussion of this in the “Users Agreement”…

The “Created with iScreensaver” overlay is what you see when using the free trial version.
To remove that, you’ll need to purchase a license code from us.

Got it! Will do so in a few days.

Thanks again.