[Solved] Screensaver on Mac tests fine but won't run on its own

The screensaver works fine when I test, but as soon as I leave it to come on by itself (or assign it to a hot corner), it starts, by going to a black screen, but then stops and reverts to the normal computer screen. The screensaver is using a fairly large .mov as its source.
Any help will be appreciated.

Try re-encoding the .mov to a ‘safe codec’, such as H.264 or PhotoJPG. This is a long-standing internal OSX bug with certain video formats.

I have exactly the same problem - I have tried H.264 and .MOV formats and it will work on the “test” on OSX 10.6.8 but not once it’s actually installed. This has put me in a very difficult situation with a client. Embarrassing. Once it’s installed you just get a black screen…any ideas? ANYONE?

I’ve tried shortening the file name (to see if that was a problem) I’ve tried all kinds of safe codecs and different file sizes - it’s not working for me at all.

You have to generate a proper movie file for it to work.
How are you generating the H264 and MOV files? What program are you using to do the re-encoding?

I used Adobe media encoder to generate a H.264 file (.mp4) and unchecked the check plugin version option and it seems to have worked.

Adobe Media Encoder: we have seen some really poorly encoded movies using this product, so we don’t recommend it. Instead, we suggest you use the $29 Apple QuickTime Pro. (The reason : in iScreensaver 4, movie playback is done using QuickTime, so it makes sense that QuickTime would be the best tool to encode the movie, since QuickTime is being used to play the movie file)

“Uncheck the check plugin version option” : can you say more? Which of the three did you uncheck? This has nothing to do with the issue and is likely a red herring.

I was advised to uncheck the check plugin option because if the machine running the screensaver does not have an up to date QuickTime it may give problems. I unchecked all options. I have not tested to see if the screensaver still works if I leave this option as default…

The plugin check is generally a good idea to leave enabled, it won’t cause any problems, other than reminding the user that their software is not up-to-date. The user can always ignore this message and continue screensaver installation.

Hi guys

Where is the “check plugin” button? I too am using Adobe Encoder CS6. Is that “check plungin” button in iScreensaver or Adove Encoder? Also thanks for getting back to me, would be good to solve this one.

I’ve found it, don’t worry - going to test now

Miked888, thanks for your help - however sadly, it still doesn’t work. Black screen - If anyone wants the assets, I can post them up on a link, but basically it don’t work on Snow Leopard. 10.6.8 - the test works after the install but once you install it doesn’t run - you get a black screen. I’ve tried encoding the mov with quicktime and Adobe Media Encoder CS6 into a H.246 (mp4 file) - any ideas? This should just work surely? I’ve literally spent about 5 hours today trying to fix this for a client, when really this should have taken 10 minutes…iScreensaver support HELP!

I was using a large .mov about 300megs with the animation codec/compression and the mac running lion didn’t like that. I then used the H.264 codec and got the file down to round 30 megs and that seemed to do the trick. What size is the H.264 file that you are using in the SS?

To everyone:

  • the “Check Plugin Version” setting has nothing at all to do with this issue. 100% guaranteed. The only reason to turn this off would be if you are intentionally trying to run the screensaver on old computers that are not up-to-date. There are some situations where this makes sense, but not many.

  • Again, we strongly recommend that you encode H264 files using QuickTime Pro. Adobe Media Encoder has, in our experience, the ability to make some truly terrible H.264 files.

If anyone is encountering this issue:

  • re-encode your movie using QuickTime Pro’s Export feature, save as H264, and try again. This always works in our tests.

  • if you have encoded the movie in H264 using QuickTime Pro, and it doesn’t work, feel free to post a URL to your file (or email us if it’s private).

The reason for this trouble is a long-standing bug in Mac OS X that has been reported numerous times to Apple, and yet sadly they haven’t fixed it from 10.6.0 thru 10.8.0…

Hi guys

Thanks for getting back to me. I did re-encode using QuickTime Pro’s exports feature to H264 - that was still causing me problems. I still can’t get it to work on my machine but sent it over to the client anyway, so they knew I’d been trying to fix the problem…and it works for them. So, I’m happy with that, they’re happy and I’m good to leave this behind. Thanks to you both for helping me out - I’ve used iScreensaver a good number of times before and it’s always worked great so I’m not sure what the buggy issue was this time - Thanks again. I hope I don’t run into it again and if I do, I’ll follow all of these steps. Just to clarify, I didn’t re-encode, as it was already encoded as you’d suggested, I did exactly what Miked888 did (untick the 'check plugin version) and that created the version that worked.

Glad you got it sorted.

Handbrake is a great (free) app to use for re-encoding videos, to avoid the black-screen bug. It also makes it easy to downsize videos for smoother playback on older hardware. Visit http://handbrake.fr for more info.