[Solved] Screensaver animation does not play on Mac

Using iScreensaver 4.38.360 and testing on Mac OSX 10.6.8.

I built the screensaver using timeline animation in Flash CS5.5, and published the screensaver using Flash Player 9.

Everything works fine on this ancient little Dell laptop that I am testing on, and works partly on the MacBook Pro (screensaver image doesn’t show in the installer). The main issue is that the screensaver loads after brief pause, but does not play the animation. Another issue is that there appears to be a black frame on the left and right sides of the stage, in other words the screensaver is not fully expanding to fit the screen either.

I’ve gotta get this fixed asap as well, the deadline is looming.

Any help is appreciated.


  • The most recent version is - if you are using build 360, please update.

  • Check your version of Macromedia Flash Player Plugin – there have been a number of updates recently which fix critical bugs.

  • Check your Mac OS for Safari updates – there have been recent updates there, as well.

  • Check your play settings within iScreensaver Designer: you may need to change the Play count (try values of “once”, “forever”, and 9999.

  • Check the stretch mode within iScreensaver Designer : it sounds like you want to choose the “Full Screen” mode.

  • Review the rules for SWF playback: http://iscreensaver.com/help/help14.shtml From your description, it sounds as if you may have a SWF with an improper timeline?

Finally, if you are still stuck: Send us a copy of your built screensaver (email to support (at) iscreensaver.com if it’s small, or email a web URL to download if it’s bigger than 10MB).


I’ve updated to, I have the latest version of Flash and Flash Player, latest Mac OS updates, set play count to “Forever” (already set previously).

Now my screensaver will not even appear on the Mac, all I get is a black screen. I am going to email you my file.

Where to I set the stretch mode? I set it to “Fill” everywhere that I can.

Also, my .swf is a 176 KB file, why does iScreensaver turn it into a 31.6 MB installer file?

Hi Breezy,

Thanks for sending us the demonstration saver.

The problem is that your SWF file is attempting to load data from the internet – when I load the file, I get the following warning from Adobe Flash Player:

Adobe® Flash® Player has stopped a potentially unsafe operation. The following local application on your computer or network:
/Users/name/Documents/Customer Projects/Breezy/breezy_screensaver/screensaver.swf
is trying to communicate with this Internet-enabled location:

Although it’s tempting to just go into the Flash Player settings and bypass the warning, this would only work on your machine, and will then fail on most other computers.

The proper way – You can use SWF files that communicate with the internet, but you need to set them up properly, as described here:

also please read:

You also asked “Also, my .swf is a 176 KB file, why does iScreensaver turn it into a 31.6 MB installer file?”

Answer: iScreensaver supports both older PowerPC (PPC, e.g. G3, G4, and G5) macs, as well as the newer Intel macs. This requires code for both platforms, which roughly doubles the size.

Also, note that the file is highly compressible – a typical build will compress down to about 9MB (plus whatever assets you include). Given the average speed of residential broadband in the USA (as of April 2011, about 5 megabits/second) this means the typical download will take on average 18 seconds. And of course, broadband speeds just keep going up.

In the future, we may drop support for older PowerPC machines, which would drop the size by about 50%.

Have you ever seen an error like that when Playback security it set to Local Only. You have seen my files, I’m not pulling anything in from the internet yet Flash Player thinks I am.

Aha – thanks for sending us the FLA files. It turns out that you had two FSCommands() in your “Actions” layer:

fscommand (“fullscreen”, “true”)
fscommand (“allowscale”, “true”)

These are the problem, as FSCOMMAND is sandboxed. Essentially what happens is that the SWF file is trying to send a command to the web-browser (which counts as “network access” ) but since you have it set for “LOCAL FILES ONLY” the security violation happens.

Fortunately, iScreensaver handles sizing & scaling automatically, so these FSCommands() aren’t needed.

Remove 'em both and it should work fine - it does in our tests here.

See also:

Per the customer “Thank you, it works for me too. That is what I call customer service!”