[Solved] Newbie playing in Monterey encountering image limit

iMacPro with LG 5k as second monitor, running Monterey, latest beta, with iScreenSaver
My playground is a folder with 225 images exported from Photo and resized to 1024x768.
Building for Mac, basically using New Project and the defaults, compression set to none.
Builds without errors.
Installs ok, select Screen Saver Options button and window comes up blank.
Let scree saver run and it comes up with error. “Error Loading Module : null”
Debug log is empty.
iScreensaver has Full Disc Access privilege.
If I delete all but 20 images and rebuild, all is ok.
I’m hoping that it may be a Monterey issue as I have many more images that I’d like to add.
Any guidance for a newbie to iScreensaver much appreciated.

Although we don’t recommend it, we’ve tested with 10000 images without problems, so clearly something else is going wrong. Would you be able to provide for us a way to download a copy of the 225 image version that gives the “Error loading module: null” error ?
With that, we should be able to quickly diagnose the issue(s).

Also, there’s no reason for you to manually resize the images, either. iScreensaver will do that for you as needed, and will usually give better performance than doing it by hand. iScreensaver will automatically handle images up to 16K pixels wide, and downconvert them appropriately.

Pick up the zip here:
[URL removed for privacy - moderator]
Thank you. Let me know if anything else needed.

Thanks, in fact we can now see exactly what’s happening - somewhere after the 20th image in your sequence, there is some bad data in the image’s “Description” field. This is happening for a number of images, and is causing a corrupted build.

There are 2 possible sources of metadata:

  1. from within the Image files
  2. from the Photos.app library
    It’s certainly possible that Monterey, being in beta, has bugs here. In any case, iScreensaver is supposed to detect and prevent these kinds of errors, so we’ll keep looking into solutions.

Please do this test:

open your project in Designer
switch to List view and make sure the “Description” column is visible:
put something in the Description field such as “TESTING”

select the first image and choose Edit/Copy
selectd all images
From the Edit menu, choose “Paste Attributes…”
Select only the Description field. De-select everything else.

(This will quickly replace all of the image Descriptions with the same value)
Try to build your screensaver again. Does it work now?

Thank you for checking it out. At least not a ‘user’ problem :slight_smile:
Only a few images actually have a description, rest are blank so garbage probably getting in there via Monterey.
No worries. Have been doing more playing, this time taking media direct from Photos.app. Slowly going through 50k+ images and clips building a screen saver that will keep the family, and me, entertained when Family Room Mac not in actual use. At 98 images and some clips and going strong :slight_smile:

The rebuild as per above with ‘Description’ filled with valid data worked.

Did another, this time sourced straight from Photos. No tweaking re compression or size.
No go until ‘Description’ pasted with real data as per above.
644 items, images, some video clips and some ‘live’ photos.
Very encouraging.

It turns out the bad data was in the source files themselves (so this doesn’t appear to have anything to do with macOS 12 Monterey). We can see the problem in 10.14.6 Mojave, for example.

We will have a beta build ready shortly - we’ll email you with info about how to test it.

Thanks again for your help!

Release 6.7.1 should fix these issues.