[Solved] Mac image-only screensaver takes 30 seconds to load or preview

It started happening when we upgraded to a registered copy. We need a fix for this ASAP

The only time we’ve seen this is when a third party product was interfering. It’s almost impossible that upgrading to a registered copy could have caused the issue. Please refer to http://iscreensaver.com/forum/discussion/comment/635 for tips & hints.

Well, it worked just fine in 3 out of 3 macs we tested, once we upgraded the software and created a new installer, all 3 Macs have this issue. This happened overnight and there was no software installation or update between tests…

I also read the entire thread you pointed me to, but that happened with Video screensavers, we’re only using small JPG’s, nothing more… I also sent you a copy of the installer so you can test it yourselves. Can you please confirm?
Thank you!

Thank you – I just tested the installer you sent us, and it looks very simple: only a few images, and it seems to work normally: It starts right up in about 2 seconds on the test machine (10.9.4).

We’ve emailed you some instructions for further investigation, please check those out and get back to us if possible.