[Solved] Getting Error "You cannot use "xx.screensaver" with this version of OS X..

it’s just 2 images with random and loop settings… Using OpenGL - built with iScreensaver 5.1.1 on an ElCap Mac and being installed on an El Cap Mac… any help would be greatly appreciated.

Can you say more? When do you see the error message? (When you open the Installer, after you install the screensaver and are looking at the control panel, or when the screensaver is running).

We certainly aren’t seeing any problems like that on our systems, and in fact the screensavers should run on OS X 10.9 thru 10.12.

Can you provide us a link so that we can download the screensaver you built? If it’s private, feel free to email us the link.

After I deploy with Jamf, when the machine launches the screensaver that message appears.

For deployment on managed systems, you may want to check out the http://iscreensaver.com/faq/

In particular, when deploying on macOS using Jamf or another product, please follow these steps.

Step 1: After building the screensaver installer, install it on a target machine as usual. You can either do the regular installation (which is for a single user and will locate the screensaver in ~/Library/ Screen Savers/ or install it “For All Users” which will put it in /Library/Screen Savers/ ).

Step 2: test the screensaver on the target machine to make sure it’s been installed correctly.

Step 3: Locate the installed .saver bundle (see step 1). Now, configure your management tool to install everything located at that location from the .saver folder recursively down.

Step 3: Important: the .saver bundle include helper tools as well as hidden folders. Some parts are code-signed. Therefore, your deployment tool must make an EXACT copy. Failing to copy some parts, or adding or removing files will generally cause the deployment to fail.

Our guess is that your Jamf configuration is incorrect, and it’s not copying the folder structure accurately.

The .saver bundle was never modified… I’m trying with the install for all users method and I will let you know if that fixes the issue.

To confirm that the deployment worked, you can execute this command:

ls -laR ~/Library/Screen\ Savers/MyScreensaver.saver

(replace “MyScreensaver.saver” with the actual name of your screensaver).

Run that command on the original installation, and again on the one deployed by Jamf, and the results should be identical.

The install for all users method worked… something was probably getting lost by doing a single user install and then pushing with JAMF.

Thanks for the help!

Glad to hear you got it working!