[Solved] Error - Mac screensaver installation

Hi there,

I created a screensaver for mac with the trial version of iScreensaver. I converted a SWF to mac screensaver.

We are testing the screensaver before purchasing. We found it worked perfectly on two of the macs we tested (I know the one is OS X 10.9 and the other OS X 10.9.2).

However testing on another machine with OS X 10.9.4 we get the following error:
“iScreensaver Error ### LaunchChildApp: NSInvalidArgumentException launch path not accessible /Users/ds36/Library/Screen Savers/iScreensaver.saver/Contents/iScreensaver.app/Contents/MacOS/iScreensaver”

Any assistance regarding the above error would be much appreciated.

Does your software support the latest 10.9.4 update?

Yes, it should work fine on 10.9.4, but it could depend on the particulars of your situation. Would you please email us with a way to download the screensaver in question, and we’ll run it on our 10.9.4 test machines?

We just ran some tests on a machine with 10.9.2, and then upgraded it to 10.9.4 - the screensaver installs and functions normally on both. There may be something unusual about your screensaver, however, so we’d like to take a look at it if you can.

Hi, thanks for your reply and assistance. I e-mailed a download link for the screensaver to your support at iscreensaver.com e-mail address.

We tested your .zip file and it works fine on all our test machines, including 10.8.5, 10.9.4, and even 10.10 betas.

We see that you have both the screensaver .app file, as well as the .zip file, stored on your server.

Please note that when dealing with .app files, they can be corrupted when copied to a non-mac-os-x file system (such as websites, dropbox-like services, or PCs running Windows, or even USB Thumb drives when formatted in FAT32 or EXFAT).

Therefore, the best practice is to always only store the .zip file on the server, and let the end-user unzip on their system. It’s also a bad idea to build your screensaver on a network drive or any sort of file-syncing drive (such as DropBox). Build on your hard drive, then zip it, then copy that to the server, then copy the zip file to the test machine, then unzip there and run.

If you’ve tried that and it’s still not working, the cause is probably due to third party software that’s not working properly.

You can run run the EtreCheck software http://www.etresoft.com/etrecheck and email us the results file. We can take a look and make some suggestions.

Thank you for the feedback! We’ll test it again and let you know.