PC Version is only showing 25% of image in top left corner

My screensaver is simple, just 5 .jpgs, no .swf, audio, or video. My problem is that on a few PCs the screensaver appears to be cropped or masked; only top left portion of the image is being displayed. Why?

Also, why does it work fine on my PC and not others running the same version of window xp pro v2002 sp3?

Also, i had created a test screensaver using the trial version and it works just fine on those machines that are having trouble with the screensaver from the registered pro version? This screensaver was created on a PC running Windows 7. The same was created using trial version on Windows XP and this is not working.

Tried letterbox, crop, custom 100% x 100% and still works fine on mine and one other computer, but not others?

Please help.

Email us with a way to download the saver and we can test it out on our systems, if you’d like.

My guess, based on what you’ve said so far, is out-of-date OpenGL drivers. This can cause all sorts of bizarre issues.

See http://iscreensaver.com/help/notes/update_opengl_drivers/update_opengl_drivers.shtml

Here is link to PC .exe. The media size is currently set to custom 100% x 100% so i’m aware of the slight distortion. As far as it being an OpenGL driver issue; that’s what i was thinking too. Thanks for checking it out:


Here is link to the screensaver i created using the trial version of the software. This version works just fine on those PC’s that we suspect are running out-of-date OpenGL drivers which makes this issue more puzzling. Is there a difference between trial version and Pro version that is causing this? Perhaps the trial version is using Ultimate version features that are not available on my Pro?


Thanks – just tested it, and not seeing any issues on our test PCs.

I do see one issue: it looks like you have disabled the “Use Short Name” feature. As noted in the instructions, doing so is risky, and can cause exactly the sorts of problems you are seeing, having to do with poorly written OpenGL drivers.

Please re-enable the short filename (on the Build tab for Windows), re-build, and re-install the saver, and I suspect it may work.

Strange. I opened the project and short name is enabled. I’ll rebuild and try again.

Of the two savers you gave us, one does have shortname enabled and one does not. We believe that having short name ON should be better. I suppose it’s possible that there’s some case where that isn’t true. Or, could it be that you mixed up the two versions?

One symptom that it’s “Short name” related: if you open the screensaver installer, and click “Preview”, it will work fine. However, if you Install the screensaver, then let it run normally, it will fail. (The difference has to do with the fact that when the OS is running it as a .SCR, it disables the OpenGL drivers when using a long name).