Fighting random screen saver activation on Big Sur - can't resume/exit the screensaver.

First off, let me say that I’m enjoying watching the iscreensaver of my 50 years of photos on my iMacPro/Monterey tremendously.
I decided to get a Mini M1 (Big Sur) and migrate my Home Automation to the M1. I use a 50inch TV as a monitor, displaying several cameras so I want that screen to never turn off.
Seems Apple has a bug, for some time now, that even with screensaver set to “never” will activate the screen saver somewhat randomly and no matter what you do you can’t get out of the screen saver, short of rebooting the Mini.
I’m wondering if there is a command line method to quit iscreensaver or any screen saver that has been invoked.
Sorry for asking, but asking is my last hope to avoid having to revert backwards.
Thanks for listening/reading. Open to any/all suggestions to try

This seems to be a known bug in Big Sur, possibly related to having multiple user accounts on the mac, and/or using Fast User Switching. Not related to iScreensaver specifically.


Sorry, didn’t mean it to sound like an iscreensaver problem. More like a long shot that screen saver experts had a way to cancel a running screen saver from the command line. I.e. login via ssh and zap the saver that’s running.
Turned off fast user switching… fingers crossed

Under Catalina and higher, 3rd party screensavers are running under a sandboxed process called legacyScreenSaver so you might be able to do somthing like this:

sudo killall legacyScreenSaver

But in quick testing, it does not seem to work for me.

Thanks. I’ll try that. Will also put my photos iscreensaver on there so that at least it’ll be something better to look at.