Error when creating screen saver "Couldn't Open File"

Good Morning

Long story short, our marketing types likes to create .mov files which we convert to a screen saver and display on half a dozen machines. Last night I went to convert his latest creation and received the following error during the windows installer build phase of the program:

Couldn’t open file ‘’ for read. is it in use by another application?

Program has worked without a hitch for some time now, and currently using version 3.5, I know 4 is out, but haven’t had a chance to purchase yet and had issues with the trial. I have restarted my machine, all the normal stuff, even installed 3.5 on another clean box, both running Windows XP fully patched.

Any thoughts?

Assistance is much appreciated.

If the error is happening when you are building from within iScreensaver Designer 3.5, then I’ll hazard a guess that perhaps you have accidentally selected the wrong movie file? (the 8F1BC327 filename is an internal filename that gets created during the build process).

Try re-opening the project, and re-selecting the proper movie file and see if that helps?

The other possibility is that the file is actually busy (e.g. you have it open in QuickTime player, or another app, or even if you are previewing it from within Windows Explorer). If this is the case, the solution is simple: quit any app that’s using the file, close any desktop windows, and re-build.

Thanks for the info.

I had thought of most of that as well. Restarted machine to break any connections to that file and figured it was internal by the program. The file I am opening in the project is simply I have tried reboot to break all connections and opened no other program but iScreenSaver, did edit project and even a new project. Even installed iScreensaver on another clean XP box with most recent apple quicktime player to ensure no other application conflicts and my machine.

I did get the following information from within iSceenSaver 4.

Pre-build Warnings & Errors: 

Item # 1 Movie : has Looping or Palindrome set in the movie. Please fix this using QuickTime Player.C:\

Sequence sequence global loop is enabled, but it contains a single item that does not loop. Suggest : set item behavior to ‘play forever’ for better results.

I was able to get it to work in iScreenSaver 4; however, it wasn’t totally pretty, long delay during the loop with black screen but I’ll take it for now. I bought iScreenSaver 4 but it won’t let me register, but that’s a whole other issue.

Thanks for the response.

“I was able to get it to work in iScreenSaver 4; however, it wasn’t totally pretty, long delay during the loop with black screen but I’ll take it for now.”

Yes, please follow the instructions as per the build warning (turn off Looping in the movie, Set the single item to “Play forever”). Go to and search for “Behavior Settings” for detailed instructions.

Re: registration – version 4.0 is a paid upgrade, so you’ll need to purchase an upgrade license. You can get your upgrade discount via the Help Desk:

Thanks again. I’ve asked the gentleman to edit the .mov file with that in mind, he’s not always responsive but will post if it does resolve the issue.

I did buy the version of 4.0 received registration key etc… When I go to register, enter our name and code after about 30 seconds I get the following error:

“I’m sorry, I was not able to connect to the server to validate this registration code. Please try again. Make sure your network is connected. Authorize the connection if requested.”

Obviously we are behind a firewall which may or may not be blocking this, hard to tell without knowing where the program is trying to go, ports etc…

To validate your registration, make sure you are using the latest ( as of today). Next, the software needs to validate by making a standard HTTP connection over port 80 to the domain

This is probably getting blocked by a firewall, either on your PC, or by a router in your office. Check with your IT/network people to see about allowing this validation request through – it only has to happen once, after which they can close up the firewall(s) again.

I am the IT people :slight_smile:

We don’t have any limits on our outbound connections, they are permitted, which makes it odd. All local firewalls are off, even tried disabling symantec. Also domain admin; however, that would have stopped me at the install. I am using the version, downloaded and installed last night. Also tried this from another machine with the same results.

My laptop is at home, will probably run home and get it to test an external connection with no firewall via my verizon wireless card.

Thanks again for your assistance.